Go2 Trap Synergy Refill

Go2 Trap Synergy Refill

10.00

Rob Papen’s Go2 Synthesizer is required for compatibility.

Reason 6.5 or higher is required for compatibility.

Over 100 seriously sick, new, morphing synthesized sounds ranging from gated choirs to evolving super saw leads! Plucked synths, poly synths, mono synths, gated, leads, and more!

100-Go2 Synthesizer Patches

Modulation wheel is routed on every patch.

Listen

Add To Cart